PHP Selector

Get Unlimited Web Hosting with Selectable PHP Versions from only £2.99 per month.

PHP Selector

The PHP Selector empowers users to determine the particular version of PHP they require. It allows ultimate versatility by offering multiple versions of PHP, with more than 120 selectable PHP extensions.

Each customer is different and has different requirements to run various web applications, software, and custom scripts. The PHP Selector is a feature of CloudLinux and CageFS which enables customers to select and optimise their PHP configuration, including modules, versions and PHP.ini settings from an easy-to-use interface to meet even the most demanding of requirements.

We offer ten hardened PHP versions (7.2, 7.1, 7.0, 5.6, 5.5, 5.4, 5.3, 5.2, 5.1 and 4.4), along with allowing accounts to select their PHP modules and PHP settings.

Bundled PHP Extensions

Frequently Asked Questions

The PHP Selector is useful for changing your PHP settings, such as:

  • Selecting the version of PHP that you wish to use. The latest version of PHP may not be the best version of PHP for your site, and by using the PHP Selector, you can try an alternative version.
  • Selecting which PHP modules you would like to enable, for example, opcache. The PHP Selector supports over one hundred different PHP modules.

The PHP Selector feature is free of charge, included as standard with our cloud web hosting packages.


We offer you the choice between versions 7.2, 7.1, 7.0, 5.6, 5.5, 5.4, 5.3, 5.2, 5.1 and 4.4.


We support over 120 different PHP modules, which includes all of the most commonly used modules. Some of the most common modules included are dom, imagick, ioncube, mbstring and json. You can access a list of all the modules we support can here.

View our web hosting packages

Got a question? Talk to our experts...